Search found 42 matches

by Q*bert
Sat Sep 20, 2014 9:58 pm
Forum: M2 Dual Extruder
Topic: Going soluble - printing PVA
Replies: 5
Views: 5642

Re: Going soluble - printing PVA

So how does it look after dissolving the PVA? How long did it take to dissolve?
by Q*bert
Thu Aug 14, 2014 8:05 pm
Forum: M2 Dual Extruder
Topic: Help!!!! Dual extruder problem
Replies: 30
Views: 11022

Re: Help!!!! Dual extruder problem

I'm using the wiring harness that came with the M@, I haven't upgraded anything. Josh - Any more thoughts about the harness? brettb and I are both using that old style harness. Because of the second extruder the signals travelling back and forth through the harness have changed quite a bit. The fac...
by Q*bert
Thu Aug 14, 2014 2:36 am
Forum: M2 Dual Extruder
Topic: Help!!!! Dual extruder problem
Replies: 30
Views: 11022

Re: Help!!!! Dual extruder problem

I've changed the E1_MS2 pin definition as you suggested and the thermistors read properly at the default 16x microstepping. But now neither extruder will work - I'd expect that for the second extruder but not the first. There was also some other weird behavior such as occasional erratic control of X...
by Q*bert
Wed Aug 13, 2014 10:00 pm
Forum: M2 Dual Extruder
Topic: Help!!!! Dual extruder problem
Replies: 30
Views: 11022

Re: Help!!!! Dual extruder problem

That shows that x1 and x2 microstepping are the only modes with MS2 LOW; since one of the changes that has occurred here is using the E1 stepper motor driver for the first time, it may be that the E1 driver's MS2 pin is behaving strangely (I actually noted in the "M350" echoes from before, that the...
by Q*bert
Wed Aug 13, 2014 8:26 pm
Forum: M2 Dual Extruder
Topic: Help!!!! Dual extruder problem
Replies: 30
Views: 11022

Re: Help!!!! Dual extruder problem

What version of the Arduino IDE are you two using? And what, if any, extra libraries do you have? I've been using Arduino IDE v1.0.5 but I also tried v1.0.4 but it made no difference. Not using any extra libraries. I've tried debugging further but with no success. The lack of debugging tools and th...
by Q*bert
Wed Aug 13, 2014 12:27 am
Forum: M2 Dual Extruder
Topic: Help!!!! Dual extruder problem
Replies: 30
Views: 11022

Re: Help!!!! Dual extruder problem

OK, a little more testing shows that, using the unmodified dual code, you can issue "M350 S1" which sets microstepping to 1 and all the thermistors read properly. "M350 S2" also works. But any microstepping higher than 2 causes reading the thermistors to fail.
by Q*bert
Tue Aug 12, 2014 11:53 pm
Forum: M2 Dual Extruder
Topic: Help!!!! Dual extruder problem
Replies: 30
Views: 11022

Re: Help!!!! Dual extruder problem

One possibly useful test - could either of you try using the same firmware as a single, with "#define EXTRUDERS" set to 1 in Configuration.h (line 65)? I can confirm, as Brett did, that changing EXTRUDERS to 1 did not change the behavior. I also confirmed that I am running with a v1.2g Rambo board.
by Q*bert
Tue Aug 12, 2014 10:30 pm
Forum: M2 Dual Extruder
Topic: Help!!!! Dual extruder problem
Replies: 30
Views: 11022

Re: Help!!!! Dual extruder problem

Q*bert and brett - what specific RAMBo revisions do you two have? And did you change the firmware at all before uploading (the steps/mm for instance)? And/or, have you changed anything in EEPROM on your old firmware? I upgraded my Rambo to v1.2g (if I remember right - I'll check tonight.) I didn't ...
by Q*bert
Tue Aug 12, 2014 1:22 pm
Forum: M2 Dual Extruder
Topic: Help!!!! Dual extruder problem
Replies: 30
Views: 11022

Re: Help!!!! Dual extruder problem

I'd reported the exact same issue http://forum.makergear.com/viewtopic.php?f=13&t=755&start=90#p4452. It looks like we've both done the same trouble shooting, let me know if you resolve the issue. After a few hours of debugging, I found that the problem is related to how 1/16th microstepping is ena...
by Q*bert
Tue Aug 12, 2014 5:22 am
Forum: M2 Dual Extruder
Topic: Help!!!! Dual extruder problem
Replies: 30
Views: 11022

Re: Help!!!! Dual extruder problem

Thanks Rick - will do.

Very impressed with the quality of the upgrade components!