BLTouch Auto Leveling Sensor

The place to discuss your hardware and software/firmware modifications...
3dPrintingMD
Posts: 278
Joined: Fri Oct 02, 2015 5:37 am

Re: BLTouch Auto Leveling Sensor

Post by 3dPrintingMD » Tue Sep 20, 2016 2:35 am

dfwspeed wrote:What changes would have to be made for those of us with a Z max endstop? Having trouble getting this to work
Would love to know this as well. Anyone have any input on this. I've updated my Rev E firmware based on the steps here, and would be happy to share once I get the Z Max figured out.

I'm waiting on my BL Touch to come in, but I;m getting everything ready for it.
M2 - V4, MIC-6 Build Plate, Astrosyn Damper's(X/Y), Rev. E, Geeetech LCD

S3D - FFF Settings https://forum.simplify3d.com/viewtopic.php?f=8&t=2367
Print Quality Troubleshooting https://www.simplify3d.com/support/prin ... eshooting/

Compsult
Posts: 1
Joined: Sun Jun 19, 2016 11:37 pm

Re: BLTouch Auto Leveling Sensor

Post by Compsult » Mon Oct 10, 2016 2:07 pm

tks546 wrote:Here's my first attempt at a mount. I haven't printed it yet just roughing it in.

-Tom
blt1.PNG
blt2.PNG
would you be willing to share your 3D Native File of the mount?

3dPrintingMD
Posts: 278
Joined: Fri Oct 02, 2015 5:37 am

Re: BLTouch Auto Leveling Sensor

Post by 3dPrintingMD » Tue Oct 11, 2016 1:37 am

Just to report back in, I ended up getting this to work.

Rev E Machines the only change for the different endstop is as follows:
#define Z_HOME_DIR -1

Unfortunately I did not fully understand how to work with it, in terms of setting the proper gap.

I am not sure if the nozzle to bed gap is controlled by M206 or M851, so I really could not get proper adhesion to the plate, and honestly gave up for the time being.
If anyone has any additional information to share on the process of the setting the end gap with the BL Touch I would love to read about it.
M2 - V4, MIC-6 Build Plate, Astrosyn Damper's(X/Y), Rev. E, Geeetech LCD

S3D - FFF Settings https://forum.simplify3d.com/viewtopic.php?f=8&t=2367
Print Quality Troubleshooting https://www.simplify3d.com/support/prin ... eshooting/

leothecool
Posts: 2
Joined: Fri Oct 14, 2016 10:11 pm

Re: BLTouch Auto Leveling Sensor

Post by leothecool » Sun Oct 16, 2016 3:03 pm

I just got the BL Touch working.

I also thought I needed to do

Code: Select all

#define Z_HOME_DIR -1
, but Marlin would prevent me from moving the bed down after I homed the Z axis. This told me the z-axis was upside-down.

what I really needed was this:

Code: Select all

#define INVERT_Z_DIR true
I also had to change steps per unit, and if you did what I did, you saved wrong values for this to the EPROM when you saved the bed gap offset.

Code: Select all

#define DEFAULT_AXIS_STEPS_PER_UNIT {88.88, 88.88, 88.88, 400, 471.50}
It took me a long time to figure out that I needed to do M502.

Here is the mount I made, and some spacers to adjust the height of the sensor:

https://www.tinkercad.com/things/dPwQaw ... ling-maimu

https://www.tinkercad.com/things/3HE28r ... ch-spacers

dfwspeed
Posts: 4
Joined: Sat Sep 17, 2016 12:10 am

Re: BLTouch Auto Leveling Sensor

Post by dfwspeed » Wed Oct 19, 2016 7:22 pm

leothecool wrote:I just got the BL Touch working.

I also thought I needed to do

Code: Select all

#define Z_HOME_DIR -1
, but Marlin would prevent me from moving the bed down after I homed the Z axis. This told me the z-axis was upside-down.

what I really needed was this:

Code: Select all

#define INVERT_Z_DIR true
I also had to change steps per unit, and if you did what I did, you saved wrong values for this to the EPROM when you saved the bed gap offset.

Code: Select all

#define DEFAULT_AXIS_STEPS_PER_UNIT {88.88, 88.88, 88.88, 400, 471.50}
It took me a long time to figure out that I needed to do M502.

Here is the mount I made, and some spacers to adjust the height of the sensor:

https://www.tinkercad.com/things/dPwQaw ... ling-maimu

https://www.tinkercad.com/things/3HE28r ... ch-spacers
I gave up on this before I saw your post. Going to try your mount and spacers and add that code and I'll report back!!!

User avatar
ryaneb85
Posts: 92
Joined: Mon Oct 19, 2015 2:03 pm
Location: Singapore

Re: BLTouch Auto Leveling Sensor

Post by ryaneb85 » Sun Oct 30, 2016 8:36 pm

I installed a BLTouch and I can get it to work as expected, but during the second/slow probe, the pin drops and strikes the bed as the bed doesn't seem to drop enough to give the probe enough clearance to deploy. I can only imagine this will result in an erroneous reading.

Anybody else having the same issue? I have been through Marlin too many times to try and adjust how much the bed drops for the fine probe, but I can't seem to find the settings. Any input would be appreciated.

Vandal968
Posts: 203
Joined: Mon Jul 13, 2015 4:30 am

Re: BLTouch Auto Leveling Sensor

Post by Vandal968 » Sun Nov 06, 2016 9:09 pm

Those of you who got it working, how do you like it?

cheers,
c

leothecool
Posts: 2
Joined: Fri Oct 14, 2016 10:11 pm

Re: BLTouch Auto Leveling Sensor

Post by leothecool » Sat Nov 12, 2016 1:02 am

ryaneb85 wrote:I installed a BLTouch and I can get it to work as expected, but during the second/slow probe, the pin drops and strikes the bed as the bed doesn't seem to drop enough to give the probe enough clearance to deploy. I can only imagine this will result in an erroneous reading.

Anybody else having the same issue? I have been through Marlin too many times to try and adjust how much the bed drops for the fine probe, but I can't seem to find the settings. Any input would be appreciated.

I don't have that problem, for what its worth. I would double check to make sure the z axis steps per unit are correct for the z axis motor you have.

ksevcik
Posts: 56
Joined: Fri Oct 21, 2016 1:07 am
Location: Houston, TX

Re: BLTouch Auto Leveling Sensor

Post by ksevcik » Sat Nov 12, 2016 7:00 pm

Z_HOME_BUMP_MM in Configuration_adv.h

Marlin apparently uses the same value for all Z-axis moves, whether they're homing or bed probing.

User avatar
ryaneb85
Posts: 92
Joined: Mon Oct 19, 2015 2:03 pm
Location: Singapore

Re: BLTouch Auto Leveling Sensor

Post by ryaneb85 » Tue Nov 15, 2016 6:27 pm

ksevcik wrote:Z_HOME_BUMP_MM in Configuration_adv.h

Marlin apparently uses the same value for all Z-axis moves, whether they're homing or bed probing.
Awesome, this looks like what I need. Will give it a try tonight and let you know how I get on.

Post Reply