Dual Extruder Firmware with VIKI LCD Panel

The official subforum for discussion of the installation and use of the official M2 Dual Extruder upgrade.
jsc
Posts: 1864
Joined: Thu Apr 10, 2014 4:00 am

Re: Dual Extruder Firmware with VIKI LCD Panel

Post by jsc » Wed May 06, 2015 10:37 pm

Maybe that firmware has the default baud rate set. Try 250000 instead of 115200.

User avatar
dsmith
Posts: 14
Joined: Fri Mar 27, 2015 7:42 pm
Location: Orlando, FL
Contact:

Re: Dual Extruder Firmware with VIKI LCD Panel

Post by dsmith » Thu May 07, 2015 12:34 am

Thanks Jsc! Yep, the Baud rate... Nailed it! now to read about an invalid extruder :)
-Don
MAJ (Ret.) Don Smith
Owner and CEO
3D Simulations, Inc.
http://www.3DSimulationsInc.com

User avatar
dsmith
Posts: 14
Joined: Fri Mar 27, 2015 7:42 pm
Location: Orlando, FL
Contact:

Re: Dual Extruder Firmware with VIKI LCD Panel

Post by dsmith » Thu May 07, 2015 2:57 am

It's fixed! Thanks to insta and jsc! I modified the firmware and now the extruders are both valid and heat as they should. I am using Simplify3D with the Viki LCD on my machines and this is perfect. Soooo, IF YOU HAVE THE VIKI LCD, install and wire the duals as MakerGear instructs, download and install the Rambo USB driver (if you have a windows machine) so the computer will recognize the printer in COM3, download the latest Arduino (1.6.4) and install it, download and unzip the attached LCD Firmware file to some folder you create. Connect your printer to your computer and install the Rambo driver (if you have not already). Once installed, open Arduino. In the Arduino program, hit the "tools" dropdown and change the board to "Arduino Mega or Mega 2560" and make sure the COM3 port is selected (your printer's port). Go to the "file" menu in Arduino, select open and find the marlin.ico file buried in the marlin folder in the attached .zip file you just downloaded. Once selected, with your printer powered up and connected to your computer, press the upload button (looks like an arrow pointing right in a circle). A few things happen and it takes a couple of minutes. Once the upload is complete, start Simplify3d and go to the control panel. Click the communication tab. You will need to set the baud rate in Simplify to 250000 and hit connect again and then it will communicate (thanks jsc). So far all is good. Can't say enough great things about everyone who posts ideas and solutions on this forum!
Regards,
-Don
RAMBo_USBdriver.zip
(5.12 KiB) Downloaded 144 times
M2_LCD_Firmware_24Vw24Vheater_-_Dual-2015-04-06.zip
(2.94 MiB) Downloaded 178 times
*EDIT: Replaced the firmware file... Had to adjust pins.h so the second extruder would extrude and changed the config so it would extrude in the right direction. Then, (and here's the most important part), I tested it! Everything worked... the 31.1 offset was right on the nose. Pics will come soon (in another topic). -Don
Last edited by dsmith on Thu May 14, 2015 1:36 am, edited 1 time in total.
MAJ (Ret.) Don Smith
Owner and CEO
3D Simulations, Inc.
http://www.3DSimulationsInc.com

fmeroney
Posts: 12
Joined: Mon Apr 06, 2015 10:22 pm

Re: Dual Extruder Firmware with VIKI LCD Panel

Post by fmeroney » Thu May 07, 2015 9:50 pm

Don,
Thanks for doing the leg work on this. Still waiting for my Dual extruder setup.. 4 weeks, yikes!

However they just shipped today, so I will be able to give it a try soon I hope.

How good are your prints with the new extruders?

fmeroney
Posts: 12
Joined: Mon Apr 06, 2015 10:22 pm

Re: Dual Extruder Firmware with VIKI LCD Panel

Post by fmeroney » Thu May 21, 2015 11:03 pm

Works great but my extrude and case fan are not turning on... Any ideas? Works when i have the stock dual firmware. Also, do the jerk rates seem high?
dsmith wrote:It's fixed! Thanks to insta and jsc! I modified the firmware and now the extruders are both valid and heat as they should. I am using Simplify3D with the Viki LCD on my machines and this is perfect. Soooo, IF YOU HAVE THE VIKI LCD, install and wire the duals as MakerGear instructs, download and install the Rambo USB driver (if you have a windows machine) so the computer will recognize the printer in COM3, download the latest Arduino (1.6.4) and install it, download and unzip the attached LCD Firmware file to some folder you create. Connect your printer to your computer and install the Rambo driver (if you have not already). Once installed, open Arduino. In the Arduino program, hit the "tools" dropdown and change the board to "Arduino Mega or Mega 2560" and make sure the COM3 port is selected (your printer's port). Go to the "file" menu in Arduino, select open and find the marlin.ico file buried in the marlin folder in the attached .zip file you just downloaded. Once selected, with your printer powered up and connected to your computer, press the upload button (looks like an arrow pointing right in a circle). A few things happen and it takes a couple of minutes. Once the upload is complete, start Simplify3d and go to the control panel. Click the communication tab. You will need to set the baud rate in Simplify to 250000 and hit connect again and then it will communicate (thanks jsc). So far all is good. Can't say enough great things about everyone who posts ideas and solutions on this forum!
Regards,
-Don
RAMBo_USBdriver.zip
M2_LCD_Firmware_24Vw24Vheater_-_Dual-2015-04-06.zip
*EDIT: Replaced the firmware file... Had to adjust pins.h so the second extruder would extrude and changed the config so it would extrude in the right direction. Then, (and here's the most important part), I tested it! Everything worked... the 31.1 offset was right on the nose. Pics will come soon (in another topic). -Don

User avatar
dsmith
Posts: 14
Joined: Fri Mar 27, 2015 7:42 pm
Location: Orlando, FL
Contact:

Re: Dual Extruder Firmware with VIKI LCD Panel

Post by dsmith » Fri May 29, 2015 4:52 pm

@fmeroney: Not sure about the fans... Try pushing the reset button and see what happens? Perhaps, reinstall the firmware after pushing the reset button? I doubt it's the wiring... As far as the jerk rates and accel, I've never messed with them. If I see too much ghosting I just slow down the print speed. I like the higher rates because ninjaflex seems to print better with faster moves.
-Don
MAJ (Ret.) Don Smith
Owner and CEO
3D Simulations, Inc.
http://www.3DSimulationsInc.com

jsc
Posts: 1864
Joined: Thu Apr 10, 2014 4:00 am

Re: Dual Extruder Firmware with VIKI LCD Panel

Post by jsc » Sat May 30, 2015 2:18 am

Do they not turn on when the printer starts, or do they stop when a print is started? In the second case, remove any M108 line you may have in your startup Gcode. If it's the first case, it's probably the firmware, but dsmith doesn't appear to have that problem.

User avatar
dsmith
Posts: 14
Joined: Fri Mar 27, 2015 7:42 pm
Location: Orlando, FL
Contact:

Re: Dual Extruder Firmware with VIKI LCD Panel

Post by dsmith » Sun Aug 16, 2015 7:02 pm

Look at the True/False settings in the attached pic under the config.h file to set the extrude direction (someone had a question about this). Due to the drive gear being placed on the opposite side, the extruder also has to run in the opposite direction.
Regards,
-Don
Attachments
Extruder.jpg
(155 KiB) Downloaded 174 times
MAJ (Ret.) Don Smith
Owner and CEO
3D Simulations, Inc.
http://www.3DSimulationsInc.com

slykly1
Posts: 1
Joined: Thu Sep 24, 2015 2:37 pm

Re: Dual Extruder Firmware with VIKI LCD Panel

Post by slykly1 » Thu Sep 24, 2015 2:55 pm

I recently purchased a 3DP dual extruder system.

I also have a Viki 1 and Viki 2 LCD panel.

Has anyone modified the firmware to work with a Dual Extruder and a VIKI 2 LCD?

User avatar
Tim
Posts: 1205
Joined: Thu Apr 10, 2014 2:19 pm
Location: Poolesville, Maryland
Contact:

Re: Dual Extruder Firmware with VIKI LCD Panel

Post by Tim » Fri Sep 25, 2015 12:47 pm

dsmith wrote:my screen looks like this picture in simplify3D... Any ideas?
Offhand, I'd say it looks like a baud rate issue. Check what the firmware is setting the baud rate to, and/or try changing the baud rate in S3D to see if you can find one that works.

Post Reply