Pausing in OctoPrint/Simplify3D

Post your advice, tips, suggestions, etc...
Post Reply
jsc
Posts: 1863
Joined: Thu Apr 10, 2014 4:00 am

Pausing in OctoPrint/Simplify3D

Post by jsc » Mon Oct 20, 2014 7:50 pm

I had cause recently to print a design I made that contained a captured nut. I used OctoPrint and Simplify3D, and thought it would be useful to write up a quick note on how to do it. You can do this by manually pausing the print, but it is better to have the pause occur automatically.

1. Generate the gcode using your slicer of choice.
2. Preview the gcode to determine which layer you wish to pause at.
3. Open up the gcode file in a text editor, and find your layer start. Simplify3D inserts comments at each layer, which makes this easy: "; layer 22, Z = 4.4"
4. Insert some gcode to raise the nozzle a bit and shove the bed forward, then pause the print:

Code: Select all

G0 Y200 Z10 F1200
M0
Note that this is in absolute coordinates, so set the Z height to something comfortably more than the current layer z height (Z10 > 4.4, in this example). M0 is the pause command for OctoPrint, and after lobbying Clayton for it, it works in Simplify3D as well as of version 2.1.1. Repetier Host and Pronterface uses "@pause" instead of M0, I believe.
5. Insert your nut or whatever, and unpause the print to continue. Don't mess about too much, as there is an idle timeout in the firmware. It is helpful to thread the nut a little ways onto a screw to place it. Make sure it doesn't stick up above the current print layer or you could catch your nozzle. ABS doesn't want to stick to steel, so the next layer might be a bit messed up, but it should sort itself out quickly.

User avatar
jimc
Posts: 2884
Joined: Wed Apr 09, 2014 11:30 pm
Location: mullica, nj
Contact:

Re: Pausing in OctoPrint/Simplify3D

Post by jimc » Tue Oct 21, 2014 12:47 am

strange you are posting this. i was about to make a thread but ill just ask it here. i was just looking through the marlin gcodes for what the command is to adjust that idle timeout. i think is 30 or 60 seconds by default. something like that anyway. whatever it is you need to be quick if changing filament mid print. just looking here at my list and i cant determine if its m84 or m85. have you changed yours jin? either one S0 disables it but i am also wondering what the "S" parameter references, seconds? i would assume you can use 0-255 in there.

User avatar
Tim
Posts: 1193
Joined: Thu Apr 10, 2014 2:19 pm
Location: Poolesville, Maryland
Contact:

Re: Pausing in OctoPrint/Simplify3D

Post by Tim » Tue Oct 21, 2014 2:37 am

I adjust this in the firmware:

Code: Select all

//default stepper release if idle (60 is way too short!)
// #define DEFAULT_STEPPER_DEACTIVE_TIME 60
#define DEFAULT_STEPPER_DEACTIVE_TIME 180
in file Configuration_adv.h. One minute is just too short for most things. Three minutes works well for me.

The code in Marlin_main.cpp says code M84 adjusts "stepper_inactive_time", with the value in seconds.
In the code for manage_inactivity(), it's clear that a zero value bypasses all the disables. But otherwise,
the value of stepper_inactive_time is unsigned long, so you can go pretty much as high as you want with
the value.

User avatar
jimc
Posts: 2884
Joined: Wed Apr 09, 2014 11:30 pm
Location: mullica, nj
Contact:

Re: Pausing in OctoPrint/Simplify3D

Post by jimc » Tue Oct 21, 2014 2:56 am

thanks tim. m84 then. in my list here m84 and 85 have descriptions that make them sound about the same. so am M84 S180 should do what you have in the firmware i guess.

Post Reply