30% Fan Speed = Off?

Ask the MakerGear community for assistance...

30% Fan Speed = Off?

Postby Gwhite » Thu Dec 07, 2017 4:18 am

I'm using Simplify3D with my M2E. I'm printing transparent PETG, and I don't want to over cool it too much in the hopes of getting the filament to fuse together better & improve the transparency. However, the model is small, so I figured I don't want it off completely, or the filament will still be soft & sticky when the extruder comes around for the next pass.

I set my cooling settings to ramp up to 10% at layer 2, 20% at layer 4, and 30% at layer 6. My assumption is that it would continue at 30% for the rest of the build. I just noticed half way through the build that the bed fan is completely off.

Am I missing something, or has my fan died?
Gwhite
 
Posts: 105
Joined: Tue Jul 11, 2017 3:38 pm

Re: 30% Fan Speed = Off?

Postby ednisley » Thu Dec 07, 2017 4:00 pm

Gwhite wrote:Am I missing something


The fundamental assumption of PWM speed control: the fan contains a simple brushed DC motor with a speed roughly proportional to the applied voltage.

A decade or so ago, small fans stopped being simple brushed DC motors and became brushless DC motors with an embedded controller converting the applied DC into multi-phase AC. The controller is basically a microcontroller running from and depending on a constant DC supply, with a power output stage producing carefully shaped waveforms to drive the motor.

As a consequence, applying PWM speed control to a brushless DC motor controller straight-up doesn't work.

For high values of PWM, the controller's input power filter can keep it alive while the motor coats through the relatively short blackouts.

For low values of PWM, the controller reboots during each PWM cycle and can't spin up the motor before the next PWM cycle kills and boots it again.

That's also why putting two 12 V fans in series across a 24 V supply doesn't work: the fan current isn't constant, they don't share the voltage equally, and one eventually dies from the abuse. Applying PWM just makes things worse.

As a result, you have maybe three fan speeds available:
  • Full on = 100% PWM
  • Half-ish speed = maybe 75% PWM (depends on the fan)
  • Full off = 0% PWM

Anything between full on and full off abuses the fan controller, so if it works for a while, that's a bonus.

The fact that all 3D printing firmware and manufacturers continue to get this wrong is ... discouraging.
User avatar
ednisley
 
Posts: 899
Joined: Fri Apr 11, 2014 5:34 pm
Location: Halfway up the Hudson

Re: 30% Fan Speed = Off?

Postby Gwhite » Thu Dec 07, 2017 9:40 pm

I know that modern fans have circuitry inside that prevents linear speed control with voltage. I just assumed that the printer designers know this and that they would just pulse them to get lower air flow. I'm more than a bit disappointed to find out that the designers haven't figured that out...
Gwhite
 
Posts: 105
Joined: Tue Jul 11, 2017 3:38 pm

Re: 30% Fan Speed = Off?

Postby ednisley » Fri Dec 08, 2017 3:55 pm

Gwhite wrote:pulse them to get lower air flow


You could insert fan on/off control codes in the layer changes, with a delay long enough to spin it up and short enough to not wreck the layer-to-layer adhesion. Ugh & similar remarks.

the model is small


Can you print half a dozen at once, rather than one at time? Having the extruder cross the perimeter on each layer does nothing good for the surface finish, but ...
User avatar
ednisley
 
Posts: 899
Joined: Fri Apr 11, 2014 5:34 pm
Location: Halfway up the Hudson

Re: 30% Fan Speed = Off?

Postby Gwhite » Fri Dec 08, 2017 7:14 pm

Eventually I will print a bunch, but I'm trying to get the dimensions & process down first. I'm currently running another model, and I had warping issues that were largely cured by backing off on the cooling. I had my process set to 40% for the upper layers, and now that i know to watch for it, the fan is doing nothing.

So, here's a proposed fix: Build a fan shroud/duct with a variable bypass feature. I've been wanting to make a shroud anyway to localize and control the cooling better. If I put a side vent that can be opened or closed, I can run the fan in the regime where it's happy, and still control the cooling. Admittedly, it won't be on the fly in the middle of a print, but it's better than the present situation.
Gwhite
 
Posts: 105
Joined: Tue Jul 11, 2017 3:38 pm

Re: 30% Fan Speed = Off?

Postby willnewton » Sun Dec 10, 2017 2:59 pm

as stated, the fan is on or off, but usually you wouldn’t use a fan for petg.

don’t have to print a bunch for testing, just print two of them 4-5 inches apart. if the part is small it won’t take long and they will print faster because you are not bumping against the speed reduction caused by printing items that take less than 15-30 seconds a layer or whatever you have as the setting in S3d. this setting is what will cause small prints to overheat and go soft if you are not careful.

i always try to stick another item in the print a few inches away. even just a round cylinder the same height as the model, if the print is small. this SOOOOOOOO much easier than what you are trying to do with the fan.

the thought that you would sit by a printer and manually slide a fan damper around as it prints is a bit....well, it is an interesting thought, but it seems like you are doing it the hardest way possible, when just adding another object and turning off the fan will probably solve your issue.
I'm finally back to where I started two days ago!

A thread with some stuff in it I update every once in a while. http://forum.makergear.com/viewtopic.php?f=8&t=9
See some of my stuff http://www.thingiverse.com/willnewton/about
User avatar
willnewton
 
Posts: 433
Joined: Wed Apr 09, 2014 8:32 pm

Re: 30% Fan Speed = Off?

Postby Gwhite » Sun Dec 10, 2017 7:14 pm

Thanks for the idea about multiple objects. I'll have to play with that.

The one time I really need a fan is for things like bridging. I'm slowly finding just how little fan I can get away with on the PLA I'm running now, but I don't have any bridging in the models I'm printing. I will also be printing some PETG soon, where cooling can help a bit with stringing.

So far I've determined that the fan runs when set to 60%, but I'm not sure if it's actually any slower than 100%.

My theory with a baffle in the fan shroud would be that I could at least have a bit more control than the present all-or-nothing system. I doubt I would adjust it mid-print. I have typically had the cooling off for the first few layers to get good adhesion & minimize warping. If I then want a bit of cooling, I can kick the fan on to whatever speed it's happiest at, and use the vents to drop the air hitting the print to an acceptable level.
Gwhite
 
Posts: 105
Joined: Tue Jul 11, 2017 3:38 pm

Re: 30% Fan Speed = Off?

Postby jk42 » Mon Dec 11, 2017 6:11 pm

Try running a M106 S255 and see if the fan comes on.
~Jason from MakerGear
jk42
 
Posts: 23
Joined: Mon Oct 09, 2017 5:19 pm

Re: 30% Fan Speed = Off?

Postby Gwhite » Tue Dec 12, 2017 3:25 pm

The fan is working, it just doesn't have much of a speed control range. I will play with the M106 g-code and see if I can map out the range of values where it actually runs. From the reading I've done, it will probably cease to respond below about 40 or 50% speed. The 24V fan (in theory) should have more control than a lower voltage fan because the drive electronics will typically die at some fixed low voltage (~ 4 or 5V). There are two critical speeds: A) at what speed setting will the fan start, and B) once running, at what (lower) setting will it stop.
Gwhite
 
Posts: 105
Joined: Tue Jul 11, 2017 3:38 pm

Re: 30% Fan Speed = Off?

Postby ednisley » Tue Dec 12, 2017 6:48 pm

Gwhite wrote:the drive electronics will typically die at some fixed low voltage (~ 4 or 5V)


While that's true, it doesn't describe what actually happens to a fan connected to a PWM-chopped power supply.

There's no "DC voltage" across the fan terminals when the MOSFET turns off, because the transistor cuts off the current through the fan. The fan rotor continues coasting, due to mechanical inertia, but the fan controller is off.

When the MOSFET turns back on during the next PWM pulse, the controller must reboot from a complete shutdown. The controller eventually starts producing the output waveforms required to spin the fan rotor, but they won't be in sync with the actual fan position (because there's no feedback from the fan rotor), so the rotor must either accelerate or decelerate until it matches the drive waveform.

The only reason this seems to work for PWM > 50% (-ish) is because the controller has time to wake up and start spinning the fan. Shorter PWM pulses don't give it enough time and the fan remains stopped.

Applying PWM-chopped power to a brushless DC fan simply doesn't work.
User avatar
ednisley
 
Posts: 899
Joined: Fri Apr 11, 2014 5:34 pm
Location: Halfway up the Hudson

Next

Return to Tech Support

Who is online

Users browsing this forum: No registered users and 5 guests