does Quick-Start run on 64 bit Ubuntu 16.04?

Ask the MakerGear community for assistance...

does Quick-Start run on 64 bit Ubuntu 16.04?

Postby jferguson » Fri Jul 21, 2017 5:31 pm

This IS NOT a request that anyone spend any significant time on this issue. I ask because the library reference error I got when I tried it looks as though the Linux application is expecting a 32 bit system. Since the windows version works for me, I suppose I'm just idly curious if anyone has gotten it to work in Ubuntu 16.04 - 64 bit.

john
jferguson
 
Posts: 80
Joined: Mon Mar 30, 2015 7:26 pm

Re: does Quick-Start run on 64 bit Ubuntu 16.04?

Postby beala » Wed Feb 07, 2018 12:33 am

I got this running and wrote up the process here: http://www.usrsb.in/m2.html

The trick is you need the 32 bit versions of all of quick start's dependencies and then you need to set the baud rate correctly.

From the write up:

In order to calibrate the printer, you need to run the MakerGear M2 Quick Start. This is compiled for 32 bit systems, but chances are you’re on a 64 bit system and will need to manually install the 32 bit dependencies.1
Code: Select all
sudo dpkg --add-architecture i386
sudo apt update
sudo apt install libc6:i386 libncurses5:i386 libstdc++6:i386 libgtk2.0-0:i386

If you try to connect to the printer without setting the correct baud rate, you’ll get a timeout. Below is how to set the correct speed for your TTY device.
Code: Select all
sudo stty -F /dev/ttyACM0 115200

You should now be able to use the Quick Start as root.
Code: Select all
cd M2\ Quick\ Start
chmod +x ./M2\ Quick\ Start
sudo ./M2\ Quick\ Start
beala
 
Posts: 2
Joined: Wed Feb 07, 2018 12:26 am


Return to Tech Support

Who is online

Users browsing this forum: No registered users and 7 guests