Kiki LCD Screen with V4 Hotend and 24V PowerSupply

Ask the MakerGear community for assistance...

Kiki LCD Screen with V4 Hotend and 24V PowerSupply

Postby jcf » Wed Sep 06, 2017 2:03 pm

Hi, I'm having issues with the firmware on my M2 printer. The printer was originally purchased in 2012. Over the summer, the school (I'm a teacher) purchased the Power Supply upgrade kit and the Electronics Board upgrade. Everything is installed correctly and the printer does operate, but I'm having issues with the Viki LCD screen. I followed the instructions (http://makergear.wikidot.com/m2-firmware) from MakerGears Wiki on which firmware to use with the old black/silver Z motor with V4 hotted. I am using Arduino 1.5.5 as per their instructions. What I am finding is:

1.) If you power off the power supply then the firmware did not save and has to be reuploaded either through the Arduino software or by disconnecting then reconnecting the printer to Simplify3d.

2.) The VikiLCD outputs complete gibberish upon repowering on, throughout prints, and randomly when sitting idle.

I'm not a programmer at all so I don't have much clue into looking into the firmware provided to debug, but I was wondering if anyone else has had the same issue and found a solution?

The prints are coming out great still, but I'd like to be able to use the VikiLCD during prints to change things without having to go through Simplfy3d.

Thanks in advance for any advice out there.
jcf
 
Posts: 1
Joined: Wed Sep 06, 2017 1:51 pm

Return to Tech Support

Who is online

Users browsing this forum: Bing [Bot] and 3 guests