VIKI2 LCD installation

Ask the MakerGear community for assistance...
Post Reply
User avatar
morganfree
Posts: 53
Joined: Mon Sep 26, 2016 10:46 pm
Location: Porto Alegre, Brazil

VIKI2 LCD installation

Post by morganfree » Mon Oct 09, 2017 1:50 pm

Hello, good morning!
This is an old subject and for what I could read, maybe unresolved?

It happens that I bought an VIKI2 and after that I read that it might be uncompatible with my M2!!!!

Anyway, now I'm fighting to install it: I was folowing the instructions from VIKI itself and from your Wiki, but none of those could actually help me.
The screen is not working, evethough I switched the various firmwares that are available on both sites (besides the one indicated as the correct).
The most I could do is to illuminate the ring... but nothing else (back screen light is on but nothing on screen and button not doing anything).

As I said I was also checking the forum, but it seems that nobody could actually make that screen work or at least nobody leaved a record on the forum. Last posts about that screen are from 2013-2015...

My machine is a 24V PS with Silver/Black Z engine and updated to V4 hotend.

Can you please help me indicating which is the right firmware an possible modifications on it in order to make it work?
I followed the wiring diagram from VIKI for Rambo (http://panucattdevices.freshdesk.com/he ... 1043587235).

I'll appreacite a lot your help!
Best regards!

User avatar
insta
Posts: 2018
Joined: Tue Sep 16, 2014 3:59 am

Re: VIKI2 LCD installation

Post by insta » Mon Oct 09, 2017 6:41 pm

I have a good deal of experience getting the Viki1 running (I have 6 of them...), but not the Viki2. It's a bit of a pain in the butt, since Panucatt and Marlin disagree about which pins should be used. The wiring diagram says one set, Marlin says another set -- both are right (since the pins are just generic I/O pins that can be remapped). If the Viki1 and Viki2 use the same-name pins on the LCD side, I'd use the M2 wiki wiring guide for it.

Or, buy a Viki1 from me ;)
Custom 3D printing for you or your business -- quote [at] pingring.org

User avatar
morganfree
Posts: 53
Joined: Mon Sep 26, 2016 10:46 pm
Location: Porto Alegre, Brazil

Re: VIKI2 LCD installation

Post by morganfree » Tue Oct 10, 2017 1:29 pm

insta wrote:Or, buy a Viki1 from me ;)
hahahaha I guess that I'm reading that phrase from you since 2013 !!! hahahaha
I thought that during these last 4 years someone could actually install one of those!

I don't know what will I do with that beautiful Viki2! I guess they focused on beauty but not on compatibility/usability! shit
I'll try a little bit more... I've received some answer from MG and waiting for an answer from Panucatt ( :? :? )
If I get it to work I'll post the results here.

If I get tired of trying with the I'll PM you later if it's for real you want to sell one Viki1! I do want a screen and stop using a computer to control the machine...

We keep talking! Thanks insta!

User avatar
insta
Posts: 2018
Joined: Tue Sep 16, 2014 3:59 am

Re: VIKI2 LCD installation

Post by insta » Tue Oct 10, 2017 4:45 pm

I'm for real, man. You figure out how to get one to Brazil you can have it for $10 + the cost of shipping. I have a shoebox full of them.
Custom 3D printing for you or your business -- quote [at] pingring.org

User avatar
morganfree
Posts: 53
Joined: Mon Sep 26, 2016 10:46 pm
Location: Porto Alegre, Brazil

Re: VIKI2 LCD installation

Post by morganfree » Wed Oct 11, 2017 8:03 pm

Great! Let me find out how to deliver it to Brazil. I'll PM you once I find out. Thanks a lot!

User avatar
morganfree
Posts: 53
Joined: Mon Sep 26, 2016 10:46 pm
Location: Porto Alegre, Brazil

Re: VIKI2 LCD installation

Post by morganfree » Sun Feb 18, 2018 5:19 pm

Good Afternoon!

Well, finally I have a VIKI2 that Insta sold me, and it's working good!!! No problems during install and I'm controlling my M2. I gave up on Viki 2... nobody seemed to install it correctly, not even MG support...

Talking about the Viki1, I noticed that when I'm printing from SD, directly from the Viki, if I try to tune something (temperature, fans, etc.), the program seems to mess up. Aparently some axis stops moving, so the print ruins... Do you know what could be causing that problem? (Seems to be some interference in the reading of the SD while messing with the controls of the Viki....)

Another question about the Viki1 would be: The firmware I got only has two preheat functions (ABS and PLA). Is there any way to add more Preheat functions (Flex, PET, nylon, etc.)? Actually, is there a way to add more functions to the firmware? I'm thinking about "Load filament and unload filament" functions, some "Clean Nozzle" function, etc. etc. I guess there should be some post about that especificaly...

That's about it so far! thanks a lot for your help, as usual!

Post Reply