M3 ID's bed rises by increments of 0.02mm every print.

Ask the MakerGear community for assistance...

M3 ID's bed rises by increments of 0.02mm every print.

Postby Retro Access » Fri Jan 12, 2018 1:51 pm

This is a situation I have been banging my head against all month. I've boiled it down to this: every time I print, I have to adjust the Z height on the Simplify3D settings up by 0.02mm otherwise it will print nothing (nozzle too close to bed.) I want the nozzle as close as possible because it mashes the bottom for a smooth surface. Every morning I reset the height by doing the "zigzag" pattern thing in Octoprint then by evening my final print of the day is usually over +0.10mm and sometimes up to approaching 0.20 in the Z height settings, by necessity.

This seems to only happen with duplication mode but I *could* be wrong given I don't care how smooth the bases are of the only things I print in single mode. But just yesterday I was printing the same thing over and over in the same place in single mode and I don't *think* this was happening, but I was using PETG which sticks much easier (and like I say, don't really care about the base quality as this part gets covered with a bit of circuit board.)

Using PLA for project boxes and NEEDING the bases to be mashed because the base becomes the top of the model, I'm seeing this constant 0.02mm creeping up with every single print.

This is printing in the exact same spot and NOT repriming with hairspray. The bed is obsessively levelled. I'm using a new bed now (broke the first one) and the same thing is happening. Which I expected because it's clearly the motor doing this or something in the code. Have to relevel it using just the centre zigzag every morning to counteract this issue.

Is there any easy fix? I don't know if my printer has always done this or whether I only noticed it when I started having it print all day every day.
Retro Access
 
Posts: 4
Joined: Fri Jan 12, 2018 1:25 pm

Re: M3 ID's bed rises by increments of 0.02mm every print.

Postby willnewton » Sat Jan 13, 2018 2:33 pm

Might be looking in the wrong place.

Might need to tighten Z endstop or make sure there is no debris on it.

Might need to tighten print head parts or chassis parts that are shifting.

Might need to adjust first layer print width % rather than Z height.

Might not have the heads set the same Z-height.

Might have TOO MUCH squish, which actually causes the edge of the printed line to raise up. Then the line beside that ridge has poor contact, and the next line and so on. It looks like poor adhesion, but it actually a symptom of being too tight to the bed.

You can diagnose this last one pretty easily by watching layer one print. Does layer one have high ridges or show areas that have a slight “curl” or wavy look when viewed at an angle? You are too close to the bed.

Are you using bed clips to keep consistent height?

How did you break the first glass bed? Chasing obsessively tight Z-heights? ;)
I'm finally back to where I started two days ago!

A thread with some stuff in it I update every once in a while. http://forum.makergear.com/viewtopic.php?f=8&t=9
See some of my stuff http://www.thingiverse.com/willnewton/about
User avatar
willnewton
 
Posts: 450
Joined: Wed Apr 09, 2014 8:32 pm

Re: M3 ID's bed rises by increments of 0.02mm every print.

Postby Retro Access » Sun Jan 14, 2018 1:06 pm

Ok I checked yesterday in single mode with multiple prints of the same file in the same spot on petg.

We recently changed from pla to petg for a part that needs to be strong lengthways - so we could print it horizontally instead of vertically just purely because it looks better printed that way. But petg is too soft for the screws we make project boxes with and also I want to mash the bottom layer. Petg is not mashed at all for the little plug we print with it.

It’s definitely rising 0.02mm on just single mode too. This is from a simple fact of printing petg so high up compared to pla, that it’s just obvious. First print of the day: very visible lines on the bottom of the part, low bed adhesion (can literally just take it off the bed by hand at finish.)

By the sixth print I was seeing definite mashing into the bed, the lines are indistinct, I had to ram the print off the bed with a knife.

By the tenth print it’s screwing up the skirt and I can tell it’s not going to print well.

So these are parts that I am printing for actual use by customers and it’s driving me a bit crazy. I *just* want to be able to tell it to print, then take the prints off the bed, then tell it to print the same again without having to load in a new file that’s 0.02mm higher every time. Also I want to be able to print perfectly every time, and set the bed at an exact position to be able to do so. I can’t do that if the bed keeps changing height, which is what it’s definitely doing and not necessarily exactly by 0.02mm - this is just what seems to “work” but I’m still getting the odd failed print.

Also, obviously - I don’t want to be leveling the bed every single morning.

I’m going to look up the info on how to adjust this stuff, this is my first 3D printer - it was bought for a business so we started out expensive. So I don’t know how to change anything mechanical bar swapping out the heads so far. I’m pretty certain it’s been doing this since we got it too, our very first print was perfect then we kept getting issues that actually caused me to go into the 3D and change the actual model to print better, but I was leveling the bed almost every day when I was figuring this out. Just because I was troubleshooting and trying to figure out why the prints were failing.

We broke the first bed by dropping it.
Retro Access
 
Posts: 4
Joined: Fri Jan 12, 2018 1:25 pm

Re: M3 ID's bed rises by increments of 0.02mm every print.

Postby insta » Sun Jan 14, 2018 7:25 pm

If you slice a simple cube, print it, measure it, then hit "print" a second time (without doing anything else), measure that, then hit "print" a third time, each box will be 0.02mm shorter?

Can you post your start/end gcode?
Custom 3D printing for you or your business -- quote [at] pingring.org
User avatar
insta
 
Posts: 1998
Joined: Tue Sep 16, 2014 3:59 am

Re: M3 ID's bed rises by increments of 0.02mm every print.

Postby Retro Access » Sun Jan 14, 2018 9:12 pm

I don’t know re. Printing a cube because right now I’m behind on demand due to breaking the glass and today I’m printing enough petg parts to last the week. Petg probably won’t measure too differently because I’m putting it at .3mm z height then just printing over and over in the same place. I can just see a visible difference in the base then later on I switch to a .32 file then a .35 file.

With pla it’s mashed into the bed by necessity then when it goes too high the first layer fails to print or prints the skirt looking blobby which is at the point I cancel the print and change the z height in simplify 3D. So I have no idea if it’d be shorter if I continued, though I assume so.

I thought this was maybe due to temperature, maybe it heats up throughout the day? But I‘ve gone a full night of no printing and still have to relevel in the morning so perhaps not.
Retro Access
 
Posts: 4
Joined: Fri Jan 12, 2018 1:25 pm


Return to Tech Support

Who is online

Users browsing this forum: No registered users and 5 guests