controller board fan trouble.

Ask the MakerGear community for assistance...

controller board fan trouble.

Postby classicvideogamer » Sat Feb 03, 2018 3:33 pm

Hi,

I thought I'd do a super simple fan upgrade to make my m2 quite. But now my fan isn't working at all. In the below picture, does that right light tell me anything ? Also if you notice the two wired towards the bottom of the screen that go to the fan, they aren't getting significant voltage ? Any ideas what I did wrong, or how I can get back to fan working? What am I doing wrong ?

Image

Thanks

Jeff
classicvideogamer
 
Posts: 43
Joined: Thu Aug 06, 2015 12:34 am

Re: controller board fan trouble.

Postby ednisley » Sat Feb 03, 2018 4:53 pm

classicvideogamer wrote:they aren't getting significant voltage


Replace "heater" with "fan" in this post and you'll see how the MOSFET controls the fan:
http://forum.makergear.com/viewtopic.php?f=2&t=3961&p=27877#p27877

does that right light tell me anything


If I have the location right, it's labeled FAN1 and shows the FAN1 MOSFET is turned on.

my fan isn't working at all


Is the wiring polarity correct? I see two red wires twisted to the connector (presumably) going to the fans (it has loose ends now), which would give me a 50% chance (pronounced "dead certainty") of getting it wrong. The fans should survive being connected backwards, but avoid doing it for very long.

Also, insert my standard rant about wiring BLCD fans in series to "share the voltage" right here.
User avatar
ednisley
 
Posts: 942
Joined: Fri Apr 11, 2014 5:34 pm
Location: Halfway up the Hudson

Re: controller board fan trouble.

Postby classicvideogamer » Sat Feb 03, 2018 5:10 pm

Hi Ednisley,

Thanks for taking the time to reply.

All fo the wiring is how it came from the factory (I didn't do any wiring) - years back (so I'm assuming it is correct). I haven't changed anything. Those two exposed wires are from the original location of the fan. I was assuming they would connect red to red on the fan, and black to black on the fan, no ?
classicvideogamer
 
Posts: 43
Joined: Thu Aug 06, 2015 12:34 am

Re: controller board fan trouble.

Postby classicvideogamer » Sat Feb 03, 2018 5:11 pm

confirmed fan1 labeling on that.
classicvideogamer
 
Posts: 43
Joined: Thu Aug 06, 2015 12:34 am

Re: controller board fan trouble.

Postby ednisley » Sat Feb 03, 2018 6:56 pm

classicvideogamer wrote:how it came from the factory


Objection withdrawn!

Match the colors and it should be all good.

However, my rant about not putting fans in series applies in particular to different fans.

Compare the fan labels: if your "upgrade" fan has a different voltage or current than the original fan, then you can't just swap it for the old one. Neither fan will see the proper voltage or current and neither will work as intended.

Basically, you can do an exact replacement or you can change both fans, but it'd be better to actually run the poor things at their rated voltage.

You can either use 24 V fans (assuming that's the power supply voltage) or a boost/buck converter to get 12 V from 24 V.

However, you cannot use PWM speed control with a converter; always set the fan to PWM 0 (off) or PWM 255 (full on).
User avatar
ednisley
 
Posts: 942
Joined: Fri Apr 11, 2014 5:34 pm
Location: Halfway up the Hudson

Re: controller board fan trouble.

Postby classicvideogamer » Sat Feb 03, 2018 9:13 pm

Ok, so I am still stuck. If anyone can give me some troubleshooting advice (in easy to understand terms), that would be great - as my fan really isn't working at this point. Thanks.
classicvideogamer
 
Posts: 43
Joined: Thu Aug 06, 2015 12:34 am

Re: controller board fan trouble.

Postby classicvideogamer » Sun Feb 04, 2018 10:54 pm

Happy to report back that I'm AOK now. Everything seems like it is working. I wish I knew exactly what I did that fixed it all up, but I definitely, did a careful reseating of the electronics.
classicvideogamer
 
Posts: 43
Joined: Thu Aug 06, 2015 12:34 am


Return to Tech Support

Who is online

Users browsing this forum: No registered users and 4 guests