BLTouch issues

Ask the MakerGear community for assistance...
Post Reply
Posts: 13
Joined: Fri Jul 10, 2015 6:41 am

BLTouch issues

Post by quentinthornton » Thu Jul 19, 2018 11:26 pm

Hey guys, I've been trying to get my bltouch sensor to work for quite a awhile now, but I just can't seem to get it. I have a problem similar to jfjohnny5
I then ran another G28 command. The bed raises, hits the probe, and instead of going up, it now rapidly descends until it hits the bottom. At that point, it comes back up about 5 centimeters.
and when I run G29, the bed goes straight down until it hits the bottom and the stepper motor strips out.

I'm 99% sure the sensor itself is working fine, as I did as followed here:
M119 should report triggered if you remove the cable at the BLTouch end.

If it says open then there's a problem. Remove the cable at the RAMPS end. If M119 reports triggered then the cable is bad (most likely signal is shorted to ground). If M119 reports open then either the RAMPS/2560 is bad or you're not running the config you posted.

If the above checks out OK then try this:

Code: Select all

	Testing a BLTouch with serial number:
	1. Connect BLTouch, power up controller and upload the firmware
	2. Blue LED will be ON if a servo signal is present.  Blue LED is faint.
	3. Issue "M119" ; should return OPEN. If not check that the BLTouch is enabled in the configuration. If enabled then check wiring and check that the correct pin is being used. Also check that Z_MIN_ENDSTOP_INVERTING and Z_MIN_PROBE_ENDSTOP_INVERTING are both set to "false".
	4. Issue "M280 P0 S10" ; should deploy the probe and the orange LED will be OFF.
	5. Issue "M119" ; should return OPEN
	6. Issue "M280 P0 S90" ; should stow the probe and the orange LED will be ON
	7. Issue "M280 P0 S60" ; puts it into the M119 test mode.
	8. The probe should remain stowed and the blue LED should be OFF. If it's ON then the unit needs to be adjusted.
	9. Issue "M119" ; should return TRIGGERED
	10. Issue "M280 P0 S160" ; returns it to normal operation
	11. Issue "M119" ; should return OPEN.
and it reported triggered whenever the sensor was triggered, and open whenever it wasn't. Which obviously means it's working...right?

I have one question though. Is it suppose to report a z_max? Why isn't there one for the x or y?

Code: Select all

READ: Reporting endstop status
READ: x_min: open
READ: y_min: open
READ: z_min: open
READ: z_max: open <- is it normal for there to be a z_max?
and in case it's of any importance, the z_max always stays on open, even when the trigger is activated.

Anyway, I'm pretty sure everything is wired correctly, so I believe the problem is in the g-code. I've been toying with it for quite a while so I'll just try to give a quick summary of what I've done

First I followed what jturrell said

Code: Select all

Find this line and ensure it is set to false:
const bool Z_MIN_ENDSTOP_INVERTING = false;

Uncomment this line:

Update the lines below with these numbers: (You can play with these to fine-tune.)
// set the rectangle in which to probe

Update your probe offsets:
// These settings assume you're using the same filament guide as I am.
#define Z_PROBE_OFFSET_FROM_EXTRUDER -2.05 // You may need to play with this to get the right "squish" on your first layer.

Update the following setting:

Update the lines below to define servos and endstops. Make sure these lines aren't commented out:
#define NUM_SERVOS 1 // Servo index starts with 0 for M280 command
#define SERVO_ENDSTOPS {-1, -1, 0} // Servo index for X, Y, Z. Disable with -1
#define SERVO_ENDSTOP_ANGLES {0,0, 0,0, 10,90} // X,Y,Z Axis Extend and Retract angles

Save the sketch. There are other settings you can play with in Configuration.h, but these are the important ones.

Step 10: Navigate to the Pins.h sketch.

Search for the "Rambo Pin Assignments" section.
Add the following line just before the "#endif //RAMBO" line:
#define SERVO0_PIN 22
I also changed the steps per unit

Code: Select all

#define DEFAULT_AXIS_STEPS_PER_UNIT {88.88, 88.88, 88.88, 400, 471.50}
After that I changed each of these settings (but not at the same time. Every time I changed them I would revert the code back to what it was previously, and then I would change just one setting)

Code: Select all

#define Z_HOME_DIR -1
#define INVERT_Z_DIR true
HOMING_FEEDRATE value for Z from 15*60 to 10*60
uncommented #define DISABLE_MAX_ENDSTOPS
I've tried pushing in the pin before the nozzle reached the bed and it seems to have no effect whatsoever.

I've read through the entire BLTouch Auto Leveling Sensor topic and I'm 99% sure I tried everything there multiple times.

I got my printer in 2013. I believe it was the one that came just after the separate 19v and 12v power supplies. The only thing I modified electronically was moving the z-endstop to the top.

Here's a link to my configuration.h file:

Thanks for your time

Posts: 13
Joined: Fri Jul 10, 2015 6:41 am

Re: BLTouch issues

Post by quentinthornton » Mon Jul 23, 2018 10:51 pm

Anyone have any ideas at all? Even a thought? I'm really frustrated because I believe the sensor is working correctly, but it seems that the printer 'ignores' the bltouch's signal. I feel as if it's just one thing that I'm missing in the settings, but I don't know what it is. Anything is appreciated

Posts: 458
Joined: Wed Jan 31, 2018 11:36 pm

Re: BLTouch issues

Post by airscapes » Mon Jul 23, 2018 11:29 pm

I can't help you but I do visit the forum frequently and I can tell you not many folks stop by real often. May take a week or more for a responce

Posts: 7
Joined: Sun Feb 25, 2018 7:23 pm
Location: Michigan

Re: BLTouch issues

Post by boucha18 » Wed Jul 25, 2018 2:12 am

I have a printer that is older than Rev E and use the latest version of Marlin. It uses the BLtouch without any issues and is likely easier to update than the old Rev E firmware you are using.

Double Check the wiring.... The 3 wire pair should have a +5 V, Ground and Signal (the far pin)
Motor Extension Pins
MX3 O O O - +
MX2 O O O - +
MX1 O O O - +
Servo Pin PA0 (44) The pin is 44 by default for MX1 in pins_rambo
Then there is the end stop which uses just the ground and the signal pins.
Zmin (black to - and white to S)
+ - S

But other issues I see are that you look to be homing to max which is going to drop the bed. The max is on the bottom which happened when you put the endstop down there.

So double check that you have it set to move in the right direction with the following (not sure if this is correct on yours since it is older)

#define INVERT_Z_DIR false //v001 9/24/2015 // For MakerGear M2, black Z motor, leave "false"; for older black and silver Z motor, set to "true"

Set your home direction to -1 if you want it to home to the top. Should be:
#define Z_HOME_DIR -1

Posts: 13
Joined: Fri Jul 10, 2015 6:41 am

Re: BLTouch issues

Post by quentinthornton » Thu Jul 26, 2018 3:51 pm

Thanks guys I finally got it working. I followed boucha18's instructions to
#define INVERT_Z_DIR false //v001 9/24/2015 // For MakerGear M2, black Z motor, leave "false"; for older black and silver Z motor, set to "true"

Set your home direction to -1 if you want it to home to the top. Should be:
#define Z_HOME_DIR -1
and it immediately worked :D Guess I didn't try them at the same time.

Anyway thanks so much I was getting real frustrated

Post Reply