M2 Rev.E won't remember starting height

Ask the MakerGear community for assistance...
Post Reply
Moonswift
Posts: 1
Joined: Sun Dec 02, 2018 4:11 pm

M2 Rev.E won't remember starting height

Post by Moonswift » Sun Dec 02, 2018 4:19 pm

I have owned my M2 for 2 and a half years now and I have set the starting height and leveled the bed dozens of times.

Recently I had a worn out filament drive which also resulted in a clogged nozzle. The nozzle has been unclogged and the drive replaced. Since I had to remove the hot end at one point I reset the bed starting height. It was too far away and I've been VERY accurate before. I was shocked and tried another print with more surface area on the glass WITHOUT changing any settings. Suddenly the nozzle was smashing into the glass, causing filament to squirt out the sides and making an ugly "elephant's foot" on the bottom of my print. I didn't change anything and I was super confused how I got these two extremes.

I tried leveling the entire bed, and also setting the bed height another 4 times. No matter what I do right now, the nozzle starts too far away from the bed. It's not terribly bad, but it's really not ideal. Prints stick but the bottom of the print isn't smooth. Like I said, I do know how to set the height. I use the Quick Start program by Makergear to do so. Is there anything else that could be going on? Or perhaps some step I'm missing??? I can't figure it out for the life of me.

airscapes
Posts: 260
Joined: Wed Jan 31, 2018 11:36 pm

Re: M2 Rev.E won't remember starting height

Post by airscapes » Tue Dec 04, 2018 1:58 am

First home the Z heat the nozzle and remove the filament and clean the tip of the nozzle with a paper towel while it is at temperature
In the terminal window turn off auto scroll an enter M503
It will return a bunch of info
Look for M206 there will be X Y and Z info, Z should be 10.xx
enter M206 Z10.60 ( a good starting point)
enter M500 (saves the settings)
enter M503 and make sure you 10.60 was saved

Loosen the screw holding the hot end on and push the hot end up into the bracket as far as it will go and snug the screw
In the terminal window run G28 which will home all 3 axis
next input the following line G1 F1000 X100 Y125 Z0
that will put the nozzle in the center of the plate ready to print.
Now take your blue feeler gauge and put it under the nozzle and loosen the the screw so the hotend drops down on the feeler gauge.
Tighten the screw.
Home the machine, heat the nozzle and put your filament back in.
Print a calibration square and see if it is the proper height.
if too tall you need to increase M206 Z10.60 by the amount that you are off.. Higher number move the starting height closer lower numbers move the starting height farther away.. backwards to what your brain thinks.

This is the instructions from maker gear support which is what I just explained to do in less detail.
I never use that app, always print a single wall square that is 2mm tall and measure, then adjust M206 accordingly..
Hope this helps!

How to alter your Z-offset with the M2 Rev. E:
You can fine tune the bed height without the QuickStart App. It involves sending gcode commands to your printer which can be done in the QuickStart App, PronterFace, or the Machine Control Panel in Simplify3D.

1. Reset your printer so that you are only saving the changed Z-offset to your Rambo board. Navigate to whatever communication platform you choose. And connect to your printer.

2. It may start updating with temperatures every few seconds. It is best to shut this off. (For example, in the Machine Control Panel of S3D press the “Verbose” radio button.)

3. Next, send a “M503” command. This will display your printers settings stored in EEPROM.

4. Look for an M206 in the communication window, these are your offsets for every axis. Then find what value is set for Z. It should be something around 10 to 14 (the unit is millimeters).

5. If you make this value larger your bed will start closer and if you make it smaller your bed will start further away.

6. Enter a new z-offset with “M206 Zxxx” (replace xxx with whatever number you want).

7. Send a “M500” to save the Z-offset to your printer.

8. The new offset will only be used after you home the Z-axis. this can be accomplished by printing something (most gcode has a homing command at the beginning) or manually sending a “G28 Z”.

You should be very careful when bringing the bed closer to the nozzle. If it goes to far you could damage your hotend or break the glass.

Ideally, while the bed is level and your bed and extruder are at operating temperature, your nozzle should just touch the bed when the z-axis is at zero. You can send a “G1 Z0” to your printer to move the bed to the 0 position on the Z-axis.

Post Reply