Page 1 of 1

M3 ID won't hold bed level and other problems.

Posted: Sat Feb 02, 2019 1:12 pm
by ManGoat
Hey guys,

I have just received my new M3 ID. I do love the printer and have made some amazing prints. However, after a few days I'm running into more than a few problems which are making me sad, to be honest. The major problem is that the bed refuses to hold level, according to octoprint's bed leveling wizard. I level the bed to within a few percent of perfectly level, the software says it's good enough, I print for a day, check the level again, and it's lowered out of level. This is more frustrating than anything and I don't know what to do. I believe there's something screwy because at one point while I was raising the bed one of the hold down clips broke.

Another problem is while I'm using the leveling wizard, in-between each level check, I have up go back to the control window and put the extruders back to home or the left one will physically ram into the right one. Even with doing this at the end of the leveling check the right extruder, which is pressing on the micro switch endstop still rams into the end causing the belt to grind.

The third problem is also related to the z axis. During about a 4 hour print of a very detailed figure at a 0.05 layer height the print fails. This seems to happen at a specific height and in two different models that I've tried to print. The extruder isn't clogged and I don't think it's stripping the filament because if I let the print continue, because I'm sleeping or in the other room, there's a blob of molten plastic when I come back. I'm going to do a test later today with differing later heights. I printed a model that was taller but used 0.1 layer heights and it didn't fail at that height. So I'll try different layer heights to narrow down the problem.

All in all, I love my printer and have gotten some amazing results. However these problems are making me sad and a little frustrated, especially the bed leveling issue. So any help at all is appreciated. Especially since it's the weekend and I can't get support on the phone until Monday. Thanks in advance!


I'm speaking with support as well which is great. This was written on Saturday and since then I've fiddled with Simplify 3D settings, got some things wrong, fixed those, got some things right. I'm now currently in the middle of a long print, which is going okay, it has some problems but those are related to settings for keeping the PVA nozzle happy and priming things.

Anywho, I had a thought when I was fiddling with things. It seems, to me, what is happening is related to the physical movement of the z axis and not leveling. As in, the bed actually stays level, however the motor / guides / screw / backlash / something isn't acting properly and slowly getting out of sync with things. So when I run the leveling wizard, after a few prints, the wizard says to raise the bed up because it is indeed lower.

I've run the cold adjustment on both nozzles, the hot adjustment, the saw-tooth pattern, everything. Heck I even lowered the bed screws significantly before doing the cold adjust so that I didn't run out of threads to raise the bed because the leveling wizard always asks to screw them in. After I dial things in, the printer is capable of phenomenal things for the first few prints, but after that the height starts to go out and I get layers not adhering, sloppiness in the lines and whatnot. I'm sure it's something simple that I'm overlooking. Thanks again and hope to hear from you all soon!


Re: M3 ID won't hold bed level and other problems.

Posted: Tue Feb 05, 2019 7:54 am
by Roland
I have had the problem with the extruders running into each other on the bed level check. In my case, it was because I had canceled a duplication mode print. This means the end script didn't get run, which leaves the extruders in an odd state. Would be nice if octoprint ran the end script when cancelling a print.

Re: M3 ID won't hold bed level and other problems.

Posted: Wed Feb 27, 2019 3:03 am
by ManGoat
Hey Roland,

You are spot on with the dupe-mode making the extruders knock into each other! Thanks for that.

Unfortunately I am still having problems with the bed leveling. No matter what I do it seems that if I want to have a successful print I must take the bed off, clean it, cold adjust, hot adjust, bed level, and then try top print. The bed-mesh leveling that is supposed to happen just doesn't seem to work for me. As an example, I just leveled the bed, after that I started a print. I noticed that the print, at 0.10 layer height, had some seriously inconsistent first layer problems. I aborted the print and peeled it off and went to the leveling wizard. This then checked the bed and said that each corner requites a 1/4 CCW turn on the screws. Which it shouldn't because it was leveled not 5 minutes ago before the print. This is becoming frustrating / troublesome because I really want to use this printer to its fullest potential and get some good looking and display quality parts out of it but it is proving to be almost impossible. It will print at 0.2 reasonably fine, but I feel that is because the margin for error is much greater. Now when I first got the machine, I managed to have it print at 0.1 and even 0.05 without any of these problems. I am not sure what to do or if I am doing anything wrong.

Sorry, I'm just really bummed that I spent a huge chunck of change, for me, on a product that is said to be pro-sumer and a production machine but it can't really do much more than a machine which would have been 1/2 to 1/4 of the price.