Page 1 of 1

Ethernet Connection Failure

Posted: Sat Aug 03, 2019 10:25 pm
by GBuchwitz
I bought an M3-ID two years ago. After working with MG Tech Support for several weeks I gave up trying to establish a reliable WiFi connection and then found that a Netgear Ethernet over power solution worked reliably.

However, today I couldn't connect my M3. MG's "Find-My-Printer" application couldn't see it. My M3's rpi typically emits a second pair of tones several seconds after power up. I suspect these tones indicate that the rpi has detected an Ethernet connection. I no longer hear this second set of tones.

It looked like my EoP adapter wasn't detecting an Ethernet connection either. I first tried connecting my M3's rpi to an alternate EoP adapter which showed Ethernet activity. I then tried connecting my M3 directly to my modem. Unfortunately my M3 still would not emit the second set of tones, nor could the Fnd My Printer tool detect a network address for my M3.

I also tried resetting my rpi (both the quick press and the 60-second approaches) as well as resetting my EoP adapters. No change.

My hunch is that a power surge zapped my adapter and my rpi, but I don't know how to troubleshoot a problem like this. I've ordered a replacement EoP adapter, but it appears that there's also a problem with my M3.

Any help would be appreciated. Thanks!

Re: Ethernet Connection Failure

Posted: Sun Aug 04, 2019 6:07 pm
by makeal
When you connected RPI directly to your modem do you get a link light for that port? If power surge zapped your EOP adapter chances are it also zapped your rpi ethernet port. I had that happen during lightning strike. My RPI that was on my standby generator lost its ethernet port and serial port