Page 1 of 1

bed upgrade -fried my motherboard - tiny fuse

Posted: Sat May 30, 2020 6:51 am
by Brit
I may have fried my motherboard upgrading to a 4 point bed and new heating bed. I’m a novice with electronics. I still don’t know if I inserted the thermostat connector in the right way (no instructions on this), but I think that they are the same the same direction as my other newer printer.

I tried upload using the correct older Arduino (after initially mistakenly uploading using the older version and trying the Quick Start app). The printer no longer connects, and the MB fan no longer works (I tried 2 fans. Albeit the little green light in the front goes on and the USB makes a sound when inserting and taking it out).

The image of the MB that attached names 3 fuses. Two of the fuses are tiny. I have no idea how to get them out (with tweezers?). Or if they have blown.
RAMBo Board.png
I did a Google search for the 04448005.MR fuses and couldn't find a place in New Zealand that sells them (but I did find a NZ site that appears to be based in the US. It costs about 5 times the value of the fuses to send them here). I’ve emailed a friend who knows a little about this stuff who may be able to source them.

Any suggestions on getting this machine working... and if i need them, where one might find these tiny fuses this part of the world?

Re: bed upgrade -fried my motherboard - tiny fuse

Posted: Mon Jun 01, 2020 4:56 am
by Brit
  • Hopefully one of these fuses is the culprit (although I just checked with a voltmeter, and they seemed OK?)? Does anyone down-under reading this post know where to find these fuses?
I have been looking far and wide in New Zealand. If its not them could it a problem with uploading the firmware with the wrong ardiuno?

Re: bed upgrade -fried my motherboard - tiny fuse

Posted: Tue Jun 02, 2020 1:02 am
by ednisley
Brit wrote:
Mon Jun 01, 2020 4:56 am
they seemed OK
A fuse is basically binary: if the ohmmeter (1) shows nearly zero resistance from one endcap to the other, then the fuse is good. If it shows "open" / "overload" / whatever, then the fuse is bad.

New Zealand seems like a great place to live, but sending anything there is expensive.

If they're still zero ohms, then reinstall them, because they're not the problem.

The thermistor isn't polarized, so if you've got it on the right pins, you're good to go. While you have it unplugged and the ohmmeter handy, measure the resistance at the connector: it should be around 100 kΩ and decrease when you hold it between your fingertips.
after initially mistakenly uploading using the older version
The printer no longer connects
You must use the correct serial port (which can change seemingly at random), the correct data rate (which should be 115200 baud) for the serial monitor, and the correct Arduino flavor (which should be "Arduino Mega or Mega 2560").

Make sure you have all that set correctly, pick the correct Marlin version, and give it another try.

It helps to keep copious notes of what you're doing, because it's impossible to remember all this stuff … [grin]

(1) Ohmmeter to measure resistance, not voltmeter to measure voltage. These days, the difference is just a twist of a dial, but be sure you're measuring the right thing!

Re: bed upgrade -fried my motherboard - tiny fuse

Posted: Wed Jun 03, 2020 2:46 am
by Brit
Thanks. The Mother Board now appears fine and the correct firmware is uploaded. It had something to do with the new z stop (now placed on the bottom of the z shaft) turning the usb connection off.

The problem may be slowly progressing with the US support guy after a week...each question takes 24 hours to answer and 3 days on a weekend because of the radical time difference, and the answers are sometimes confusing or seemingly irrelevant (though Its probably just me as a novice geek). So I'm always hoping for a better answer here.

However now when going into the quick start app, it starts, but it does not behave correctly. I’ve tripled checked that the firmware is correct. And I have attached a longer video illustrating the problem. If I lift the bed a bit as I click on the quick start (as in the second half the attached video), it behaves slightly differently, but still fails.
quick start glitch 1 and 2.mp4
(7.35 MiB) Downloaded 87 times

Re: bed upgrade -fried my motherboard - tiny fuse

Posted: Wed Jun 03, 2020 2:08 pm
by ednisley
Brit wrote:
Wed Jun 03, 2020 2:46 am
the new z stop (now placed on the bottom of the z shaft) turning the usb connection off.
The switch cable is backwards in its socket.

The (polarized) jacks on the PCB have three pins: [S - +]. The switch pin ("S") is on one end, with the common ("-") and 5 V ("+") pins adjacent to each other.

The (non-polarized) plug on the cable has three positions, but the switch has only two wires. When you insert the connector backwards, the switch wires connect to the wrong pins.

Everything works fine until the switch closes, whereupon it shorts the power supply to ground and resets the microcontroller.

You're not the first to do this and definitely won't be the last … [sigh]

Re: bed upgrade -fried my motherboard - tiny fuse

Posted: Thu Jun 04, 2020 11:41 am
by Brit
Thanks for your help. Turning the Z motor wire connector around 180 degrees solved it. The motor was turning the wrong direction.

I managed to get up early enough to call Makergear (a 16 hour time difference). They told me to turn it around - the firmware was faulty.

And apparently I had initially plugged the z stop connector to the wrong plug (the min plug instead of the max plug as on the motherboard image above). That mistake for some reason caused the USB to fail to connect to my laptop, and the motherboard fan not to run - which led me to believe that the motherboard was fried. All is good now with the best 3D printer in town!!