M3 Wi-Fi Connection Problem

Need some assistance getting started...post here...
GBuchwitz
Posts: 32
Joined: Sat Jul 29, 2017 4:18 am

M3 Wi-Fi Connection Problem

Post by GBuchwitz » Sat Jul 29, 2017 4:50 am

Hi. I just received an M3 today, and have been unable to establish a connection with it via my Wi-Fi network.

I can establish a connection between my laptop and the M3's hot spot. At that point I'm assuming that I'm browsing OctoPrint which is running on the M3's processor (right?).

But then in Step 3 (per setup.makergear.com) after I click the "Wireless Connection" button and enter my home Wi-Fi network password (to connect the M3 to my network), the process fails... redirecting my browser to my internet provider's web site which reports that it can't find m3printerxxxxx.local.

Before OctoPrint's page disappears, it suggests that I attempt to access Octoprint directly if the connection isn't made. How can I do this if Explorer can't find m3printerxxxxx.local?

Any help toward successfully getting my M3 connected to my home Wi-Fi network would be appreciated.

Thanks! - guy

TappedOut
Posts: 5
Joined: Sat Jul 29, 2017 7:54 pm

Re: M3 Wi-Fi Connection Problem

Post by TappedOut » Sat Jul 29, 2017 8:11 pm

Configured mine with no problem this week!
Don't use Windows Explorer or Edge, use Google Chrome.
Followed the setup and worked fine.

Good luck,
Larry

GBuchwitz
Posts: 32
Joined: Sat Jul 29, 2017 4:18 am

Re: M3 Wi-Fi Connection Problem

Post by GBuchwitz » Sun Jul 30, 2017 8:19 am

Larry,

Thanks for the suggestion. I eventually established a connection with my M3. What I failed to understand is that when OctoPrint failed to reconnect with my PC, the M3 had already become a device connected to my Wi-Fi network. Selecting the M3 device in Windows gave me the opportunity to log into OctoPrint and step through the MakerGear Setup process.

I think a little additional explanation of this connection process would be helpful for many M3 users

- guy

User avatar
sthone
Posts: 847
Joined: Tue Jul 08, 2014 8:25 pm
Location: Connecticut
Contact:

Re: M3 Wi-Fi Connection Problem

Post by sthone » Sun Jul 30, 2017 1:46 pm

I don't have an M3 but I do use Octopi with my M2's and connecting with octopi.local (which I assume is the same as m3printerxxxxx.local) never worked for me. I have to connect directly to octopi using the IP of the Raspberry. Again I'm assuming here that's what they mean by "access Octoprint directly"

You can find out the IP of your Raspberry by connecting to your router and looking at the connected devices. If you've never connected to your router you can just google your router brand (or internet supplier) to find out how to go about that.

If that doesn't work you might want to try opening a support ticket with Makergear as there are not to many M3 users here yet.

-Steve

User avatar
Larry
Posts: 17
Joined: Sat Oct 22, 2016 12:02 am
Location: San Diego, CA

Re: M3 Wi-Fi Connection Problem

Post by Larry » Sun Jul 30, 2017 4:56 pm

To add a bit to what Steve says, you can also use a small utility, Pi Finder, to locate (or confirm) Pi-based devices deployed on your network. Once found, it's pretty straightforward to connect directly using the IP, (though I've not had problems using octopi.local to connect to Octoprint) .. I'd second Steve's recommendation to perhaps give this a shot as you work out the connection issue with Makergear.

- Larry

Ollie
Posts: 4
Joined: Wed Jul 26, 2017 8:06 pm

Re: M3 Wi-Fi Connection Problem

Post by Ollie » Sun Jul 30, 2017 5:33 pm

If you got the small tablet for your M3, it has Fing installed and Fing finds your OctoPrint among all other nodes in your network.

GBuchwitz
Posts: 32
Joined: Sat Jul 29, 2017 4:18 am

Re: M3 Wi-Fi Connection Problem

Post by GBuchwitz » Tue Aug 01, 2017 2:46 pm

First, I sincerely appreciate all of your helpful comments.

My Wi-Fi connection problem seems to be getting worse. Yesterday I was unable to fully load OctoPrint even once. I've been corresponding with Jason at MG. I suspect if he could look over my shoulder he'd immediately either know how to fix this (a Bonjour/Edge/OctoPrint compatibility problem?) or if my M3 has a problem. It's probably an operator error problem, but it sure seems like I'm following M3's instructions.

I think I'm using the correct IP address. I haven't yet tried messing with my router.

Thanks again for your attempts to help me out.

V/r, - guy

User avatar
ednisley
Posts: 993
Joined: Fri Apr 11, 2014 5:34 pm
Location: Halfway up the Hudson
Contact:

Re: M3 Wi-Fi Connection Problem

Post by ednisley » Tue Aug 01, 2017 6:54 pm

GBuchwitz wrote:(a Bonjour/Edge/OctoPrint compatibility problem?)
From the Octoprint FAQ:
https://github.com/foosel/OctoPrint/wik ... rosoft-and
I'm using the Edge browser from Microsoft and...

... you are running into problems with OctoPrint? No surprise there, Edge still has some serious issues. Please use a stable browser, such as Chrome or Firefox instead.
The linky in that item goes back two years, but … trying a different hammer may be appropriate.

User avatar
zemlin
Posts: 437
Joined: Thu Feb 04, 2016 9:32 pm
Location: Indianapolis, Indiana

Re: M3 Wi-Fi Connection Problem

Post by zemlin » Tue Aug 01, 2017 7:19 pm

I have had zero luck with Edge and OctoPrint.
Chrome works well, unless you want to use the GCode visualization. Then Firefox will get the job done better.

GBuchwitz
Posts: 32
Joined: Sat Jul 29, 2017 4:18 am

Re: M3 Wi-Fi Connection Problem

Post by GBuchwitz » Wed Aug 02, 2017 7:08 pm

ednisley, zemlin,

Thanks for your help! MakerGear Tech Support also suggested that I try Chrome. Initial test results are promising.

To get it to work I had to make my newly-installed Chrome the default browser (vs. Edge) and set it so that only popups from my M3's IP address would be allowed. I never was able to get OctoPrint to load in Edge using the "m3printerxxxxx" URL. I may try this tonight using Chrome.

I only had time for one print test, but this was the first Wi-Fi connection I've experienced which survived the entire heat-up, print, and cool-down process. I'm cautiously optimistic, and I've asked MakerGear Tech Support to please consider advising new M3 users regarding the current apparent Edge/OctoPrint incompatibility. This may save other network/browser/OctoPrint-challenged dummies like me hours of frustration.

I've bought both an M2 (for work) and an M3 (for home) - largely based upon Amazon's customer reviews on the M2... both of the product and the associated support community. I think MakerGear is a good company, and I want them to continue to succeed and innovate. Toward that end, I hope they adopt a policy of beta testing their printer setup procedures using not-so-tech-savvy folks and at least the most popular operating systems, browsers, whatever. With Edge being the default browser for Windows 10, given MakerGear's apparent awareness of the Edge/OctoPrint issues I'm surprised that their website and manuals don't already caution their customers about it. Paper and web sites are cheap compared to the costs of (re?)acquiring and retaining customers. Acknowledging that many would not consider the M2 or M3 to be entry-level products, the extent to which MakerGear thoroughly validates and clearly documents their software installation and printer setup procedures - making them as easy and reliable (no surprises) as possible will - I believe - give them a competitive edge in this maker marketplace.

Time to get off my soap box. Thanks again for your great advice!

V/r, - guy

Post Reply