Just setup OctoPrint. Any tips?

Have questions or comments about Simplify3D, Slic3r, Cura, Reptier, etc? Or wondering about which CAD software to use...discuss it here...
jsc
Posts: 1863
Joined: Thu Apr 10, 2014 4:00 am

Re: Just setup OctoPrint. Any tips?

Post by jsc » Wed Apr 15, 2015 3:19 am

Go to the Terminal tab. You should see M105 sent and a reply received every five seconds or so. Is that not what you see?

The "duplicate" filename is probably some interaction with the FAT format, Linux, and 8.3 filenames. Try saving it as perch.gco or perch.g and see if it happens then.

User avatar
jimc
Posts: 2884
Joined: Wed Apr 09, 2014 11:30 pm
Location: mullica, nj
Contact:

Re: Just setup OctoPrint. Any tips?

Post by jimc » Wed Apr 15, 2015 3:51 am

ill give that a shot with the names and see what happens. its definitely not every 5 sec. its more like 15. the temp graph and the actual and target temps all get updated every time it gets a response back but its few and far between. min of 10 sec and sometimes it seems longer.

User avatar
jimc
Posts: 2884
Joined: Wed Apr 09, 2014 11:30 pm
Location: mullica, nj
Contact:

Re: Just setup OctoPrint. Any tips?

Post by jimc » Wed Apr 15, 2015 4:12 am

ok i clicked on the little wrench in the upper right of the file list. one file is on the local list and the other file is on the sd card list. i had both showing at the same time which is why there were two. what is odd is why would it be on the local list if i uploaded to sd card. weird.

jsc
Posts: 1863
Joined: Thu Apr 10, 2014 4:00 am

Re: Just setup OctoPrint. Any tips?

Post by jsc » Wed Apr 15, 2015 4:28 am

I've never tried printing from SD with OctoPrint. Perhaps it works by taking the file locally then uploading to the printer's SD card?

My temperature graph updates every five seconds.

Looking through the source, it appears to be controlled by a parameter in config.yaml. Oh, there it is, in settings:

Under Serial Connection, Temperature Timeout. Mine says 5s.

User avatar
jimc
Posts: 2884
Joined: Wed Apr 09, 2014 11:30 pm
Location: mullica, nj
Contact:

Re: Just setup OctoPrint. Any tips?

Post by jimc » Wed Apr 15, 2015 4:34 am

yeah i played with the timeout but that doesnt seem to have any effect. how do you print your file? are you just using the upload button instead of the upload to sd? i would assume the upload just sends it to the sd card on the pi?

jsc
Posts: 1863
Joined: Thu Apr 10, 2014 4:00 am

Re: Just setup OctoPrint. Any tips?

Post by jsc » Wed Apr 15, 2015 4:39 am

You can drag and drop gcode files into the OctoPrint page. Left side should show Upload Locally, right side upload to SD. Or you can use the Upload buttons. I actually have my computer set up to watch a folder for new gcode files and upload them to OctoPrint and select them, so when I save a gcode file from Simplify3D, I just go over to OctoPrint and it's already there waiting to be printed. But yes, Upload just sends to the local filesystem of the computer OctoPrint is running on. It is slightly confusing with the RaspberryPi, because its only "drive" is also an SD card. But "upload to SD" means upload to the SD card connected to the printer, not the one in the Pi. I always just print from OctoPrint local files, I haven't had a failed print yet.

Change the timeout, then restart OctoPrint. Probably the easiest way is to reboot the Pi itself.

User avatar
jimc
Posts: 2884
Joined: Wed Apr 09, 2014 11:30 pm
Location: mullica, nj
Contact:

Re: Just setup OctoPrint. Any tips?

Post by jimc » Wed Apr 15, 2015 4:47 am

thats a nice bit of trickery right there lol.


jsc wrote: I actually have my computer set up to watch a folder for new gcode files and upload them to OctoPrint and select them, so when I save a gcode file from Simplify3D, I just go over to OctoPrint and it's already there waiting to be printed.

User avatar
jimc
Posts: 2884
Joined: Wed Apr 09, 2014 11:30 pm
Location: mullica, nj
Contact:

Re: Just setup OctoPrint. Any tips?

Post by jimc » Wed Apr 15, 2015 4:50 am

i changed that timeout to 1 sec and rebooted the pi and it doesnt change anything. i dont really think that is a setting for that rather than if the printer doesnt respond. i guess i just have to get used to the differences from one software to the other. as for the card, yeah i could just load it locally. i have a big enough sd card in the pi. i would never fill it.

jsc
Posts: 1863
Joined: Thu Apr 10, 2014 4:00 am

Re: Just setup OctoPrint. Any tips?

Post by jsc » Wed Apr 15, 2015 4:56 am

No, from what I can see, it directly uses that value to create the temperature poller:

def _onConnected(self):
self._temperature_timer = RepeatedTimer(lambda: get_interval("temperature"), self._poll_temperature, run_first=True)
self._temperature_timer.start()

Are you changing this setting:
Screen Shot 2015-04-14 at 11.55.19 PM.png
Screen Shot 2015-04-14 at 11.55.19 PM.png (50.19 KiB) Viewed 4615 times

User avatar
jimc
Posts: 2884
Joined: Wed Apr 09, 2014 11:30 pm
Location: mullica, nj
Contact:

Re: Just setup OctoPrint. Any tips?

Post by jimc » Wed Apr 15, 2015 4:59 am

yes the temp timeout. seems to have no effect on how fast mine responds. i set it to 1 sec, rebooted and it was till a good solid 10+ sec between the m105 being sent. i just checked it with a stopwatch. 11sec

Post Reply