Search found 44 matches

by ketil
Thu Jun 03, 2021 9:52 am
Forum: Tech Support
Topic: Uneven extrusion?
Replies: 5
Views: 1828

Re: Uneven extrusion?

Thanks for testing! The part you've printed looks acceptable for the purpose of a flexure, by my understanding. It should be printed this direction to make sure it works as intended in the openflexure microscope. Some sagging is acceptable. I've used this part to exemplify the uneven walls I get in ...
by ketil
Tue May 25, 2021 5:51 pm
Forum: Tech Support
Topic: Uneven extrusion?
Replies: 5
Views: 1828

Re: Uneven extrusion?

Hey Ed, Thanks for your input once more, getting your skilled eye on an issue is much appreciated! However, I don't think cooling is the issue either. I'm already going fairly slow, but I've tried printing this piece again, now 4 at the same time. This time I also rotated the four parts at 45, 135, ...
by ketil
Fri May 21, 2021 4:36 pm
Forum: Tech Support
Topic: Uneven extrusion?
Replies: 5
Views: 1828

Uneven extrusion?

Hi, I've been struggling a bit with uneven extrusions, especially on small tall objects. I've attached a couple of photos that show the problem, but keep in mind that these are taken through a 20x microscope, so it doesn't look quite so bad in real life. The first photo is at 0.15mm layer width, the...
by ketil
Tue May 11, 2021 12:29 am
Forum: Software
Topic: Marlin 2.0 firmware for M2 Rev E, latest bugfix
Replies: 1
Views: 3150

Re: Marlin 2.0 firmware for M2 Rev E, latest bugfix

I've just worked my way through the details. I've tried to be conservative to avoid too many changes, so I may not have all possible options enabled. Below is the complete diff of what I've ended up with, relative to the 2.0.x branch of stock Marlin. I guess it's possible to experiment more from her...
by ketil
Mon May 10, 2021 9:25 pm
Forum: General Discussion
Topic: Adapting Marlin firmware, M108 vs M42
Replies: 1
Views: 2108

Re: Adapting Marlin firmware, M108 vs M42

Update: After actually upgrading to Marlin V2.0.8, the M42 command didn't work. When I first tested, I got: M42 P6 S155 Unknown command: "M42 P6 S155" I looked at the code again, and found out that I had to enable Marlin's DIRECT_PIN_CONTROL in Configuration_adv.h. So I did that, and uploaded the ne...
by ketil
Mon May 10, 2021 8:45 pm
Forum: Modifications
Topic: Installing an E3D V6 today, what do I need to know?
Replies: 6
Views: 6956

Re: Installing an E3D V6 today, what do I need to know?

Hey Helifrek How did the hot end upgrade turn out? You mentioned that you had to print a mount. Would you mind posting the file you used? Maybe a couple pictures would be helpful. I been haveing some issues printing with PETG and I think the V4 hot end is just not up to the job. Here's a quick vide...
by ketil
Sun May 09, 2021 4:21 pm
Forum: General Discussion
Topic: Adapting Marlin firmware, M108 vs M42
Replies: 1
Views: 2108

Adapting Marlin firmware, M108 vs M42

I'm busy adapting the Marlin firmware v2 to my M2 from 2012. The original Marlin firmware adapted to the M2 had the custom command "M108" to set the speed of the system fans (electronics and hotend). Unfortunately, M108 is now already in use by Marlin. Also, hacking in a new command wasn't quite as ...
by ketil
Mon Apr 26, 2021 6:01 pm
Forum: Tech Support
Topic: How many amps for old style 12v M2?
Replies: 3
Views: 1660

Re: How many amps for old style 12v M2?

Thanks for the feedback Ed! And for the fair warning regarding the heater PSU. After melting 3 connectors I've actually given up on the heatbed, so now I almost exclusively print PLA on a bed coated with wood glue. The 12v heater took ages to heat up anyway, and finally caused enough trouble for me ...
by ketil
Sun Apr 25, 2021 5:59 pm
Forum: Tech Support
Topic: How many amps for old style 12v M2?
Replies: 3
Views: 1660

How many amps for old style 12v M2?

It seems I'm on an unfortunate streak with my M2. As I was replacing the busted fan and my botched Y motor, the power supply unit died. No idea why, I disconnected it when I was doing any work on electronics, but it's clearly dead. Didn't occur to me for a while that this was the problem, so I had t...
by ketil
Sat Apr 24, 2021 8:31 pm
Forum: Tech Support
Topic: Uneven extrusion?
Replies: 5
Views: 1876

Re: Uneven extrusion?

Didn't find any info on the motor itself. I checked around, and managed to find a similar-ish motor locally. It was a Wanhao Duplicator i3 Z-motor. The original motor didn't have a connector, the wires simply disappeared into the casing. So I had to cut the wires, and then figure out which wires wen...