BL touch upgrade for M3ID

The place to discuss the M3-ID
Post Reply
Posts: 13
Joined: Thu Dec 21, 2017 10:54 am

BL touch upgrade for M3ID

Post by zahn » Fri Jan 18, 2019 6:12 pm

Hi All, I am thinking about upgrading to the rev 1 with the BL touch, but have noticed that some users are having problems with installation and proper functioning. I just wanted to ask how people's experience has been with the probe following installation? Were you able to get it working correctly? Are there problems present with its use? Is the probe getting bent?


Posts: 11
Joined: Fri Feb 02, 2018 9:34 am

Re: BL touch upgrade for M3ID

Post by alsted » Mon Jan 21, 2019 9:47 pm

For me it works as intended and has fixed som issues. I have no bend issues with it.

Posts: 11
Joined: Wed Jun 07, 2017 1:47 am
Location: Wisconsin, USA

Re: BL touch upgrade for M3ID

Post by TerryL » Wed Jan 23, 2019 11:13 pm

I upgraded. It is doing it's job well. I'm always aware that it is there and I'm careful with it but so far so good.

Posts: 42
Joined: Sat Apr 12, 2014 7:45 pm
Location: Waukesha, WI

Re: BL touch upgrade for M3ID

Post by Q*bert » Wed Jan 23, 2019 11:50 pm

I was one that had problems after installation. The probe was not being recognized.

It turned out that the Rambo pin being used to detect the probe was defective. MG worked with me to diagnose the problem and replaced the Rambo board under warranty. Now, everything works great.

MG service was, as usual, excellent!

Posts: 6
Joined: Sun Feb 03, 2019 7:05 pm

Re: BL touch upgrade for M3ID

Post by hdlbq » Tue May 28, 2019 7:50 am

I installed my BL touch upgrade yesterday.
Everything was fine, until I saw the hotend trying to print at 10cm above the bed.
I stopped it, and saw this error message:
"Recv: error detected bl touch set_bltouch_deployed1
Recv: Error: [002]-[11] Probe Deployment Error: Please restart your printer.
Recv: Error:Error: [013]-[11]Printer halted. kill() called! The printer is now offline and will not respond until restarted."

The probe seems to be bent. I can reach the octopus, but can't connect to the RAMBo. I tried to reset it, without success.
Is it a way to downgrade the printer, to be able to use it again ?
Thanks for your help

Post Reply